Amazon Order Download Issue (European Marketplaces)
Incident Report for Brightpearl
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 25, 2019 - 12:37 UTC
Monitoring
Amazon order downloads from EU marketplaces are now downloading with full address information.

As of Friday evening (UTC) - the issue with Amazon order data was resolved - and the normal sales download process resumed. We advise manually checking all orders from Friday the 21st of June - but orders from Saturday the 22nd will have downloaded with the correct name and delivery address information.

We will continue to monitor the issue - however normal service has now resumed.

Apologies for the inconvenience caused.
Posted 3 months ago. Jun 24, 2019 - 08:19 UTC
Update
Amazon order download issue update -

At 00:00 (UTC) on the 20th of June - the order data we receive from Amazon changed format - omitting some key data required for order creation in the Brightpearl back office - primarily the ‘buyer name’ field and delivery address information.

The impact -

Order downloads from EU marketplaces will have failed to download from 00:00 UTC on Thursday the 20th of June. No orders created on the 20th will have downloaded into Brightpearl on that day.

Processing of ‘Fulfilled by Amazon’ orders will not be affected - however they will be missing some delivery address information.

The Amazon US and Canada marketplaces are unaffected by this issue.

The current situation -

We have released a temporary fix to resume order download from the affected Amazon marketplaces - which was put into place at 01:00 this morning (Friday 21st of June). Order download will have resumed at this point - and missed orders will have been downloaded.

However - as a result of the missing order data from Amazon - we are unable to create the orders with a properly populated customer name or delivery address.

Dealing with downloaded orders -

As of the 01:00 (UTC) this morning (21st of June) - orders from EU marketplaces will download into Brightpearl - however they will be missing customer name and delivery address information. To process these orders - it will be necessary to manually update the buyer name fields in Brightpearl, copying the information from Seller Central.

It is especially important to populate the delivery address name, delivery address line 1 and delivery address line 2 to ensure orders can be successfully shipped and delivered.

Orders shipped manually via Amazon on Thursday the 20th -

Due to the fact no orders were downloaded from the affected marketplaces into Brightpearl on the 20th - many customers have had to manually mark these orders as shipped in Amazon to ensure delivery requirements were met. These orders will now have downloaded into the Brightpearl back office - however - if these orders are marked as shipped now (which will be required for inventory reasons) a second shipment update would be sent to Amazon - which will result in a change to the dispatch date information. This may lead to issues with orders which had to be marked as shipped yesterday to meet Amazon shipping date requirements.

If this issue affects you - you’ll need to temporarily update your Amazon channel settings to prevent shipment updates being sent from this orders when you retrospectively mark them as shipped in Brightpearl. In your Amazon channel settings is an option titled ‘Send shipment updates for’.

You would need to update this option to ‘No orders’ (as shown above) - mark the relevant orders shipped - and then reset this option to your normal settings.

This option can be found via ‘Settings’ > ‘Brightpearl Apps’ > ‘Amazon’ and then editing the settings for the relevant marketplace.

Going forward -

We are working hard to address the root cause of the issue with Amazon to ensure order data is sent in the correct format for us to properly create the sales orders in Brightpearl.

Once we’ve progressed the issue with Amazon - regular service will be resumed automatically and no action will be required from Brightpearl or yourselves. We will post updates to this page as we receive them.

We suggest you subscribe to updates from this page so we can easily keep you up to date with any developments.

Apologies for the inconvenience caused by this issue. If you have any questions or issues around the process for dealing with orders at present - please get in touch with the support team (https://www.brightpearl.com/contact-support).
Posted 3 months ago. Jun 21, 2019 - 09:01 UTC
Update
Further updates on the Amazon order download issue -

Whilst we work on releasing the proposed fix please ensure that you ship any urgent orders directly on Amazon's end to avoid any late shipments. Do not manually create these sales in Brightpearl - as this will lead to duplicates when the issue is resolved.

Once the fix is released it will be necessary to manually update the buyer name fields in Brightpearl against all European Amazon orders since 00:00 UTC today, copying the information from Seller Central. It is especially important to populate the delivery address name, delivery address line 1 and delivery address line 2 to ensure orders can be successfully shipped and delivered. Please contact our Support team if you need further guidance or have any questions.

We are investigating resolving the underlying issue and returning the service to normal as a priority. Please accept our apologies for the inconvenience caused.
Posted 3 months ago. Jun 20, 2019 - 16:00 UTC
Identified
We are aware of an issue whereby Amazon orders from European marketplaces (UK, DE, ES, FR, IT) are not downloading into the Brightpearl back office since 00:00 UTC today. Orders from Amazon US or Canada marketplaces are unaffected.

We have identified the cause as the ‘buyer name’ field being omitted from orders in the response from Amazon. This is preventing contact records and orders from being created in Brightpearl. To circumvent the problem in the short-term, we plan to add a placeholder buyer name which will allow all missed and future orders to download.

Action is required by sellers: It will be necessary to manually update the buyer name fields in Brightpearl against all European Amazon orders from 00:00 UTC today, copying the information from Seller Central. It is especially important to populate the delivery address name to ensure orders can be successfully shipped and delivered. Please contact our Support team if you need further guidance or have any questions.

We are investigating resolving the underlying issue and returning the service to normal as a priority. Please accept our apologies for the inconvenience caused.
Posted 3 months ago. Jun 20, 2019 - 12:54 UTC
Investigating
We are currently aware of an issue whereby Amazon orders from European marketplaces (UK, DE, ES, IT) have not been downloading into the Brightpearl back office since 00:00 UTC today. We are investigating the issue as a priority and will provide further updates when available. Orders from Amazon US or Canada marketplaces are unaffected.
Posted 3 months ago. Jun 20, 2019 - 08:50 UTC
This incident affected: E-commerce Connections (Amazon).