Occasional Slow Speeds For Users
Incident Report for Brightpearl
Resolved
This incident has been resolved.
Posted about 1 month ago. Jul 16, 2019 - 13:58 UTC
Investigating
We are currently investigating an issue in which some accounts are experiencing slow loading times during general activity.
Posted about 1 month ago. Jul 16, 2019 - 12:16 UTC
This incident affected: User Interface (UI).